这个是我今年数据结构的课程设计。如果要课程设计报告书,请下载上面的
2021-12-27 14:41:30 37.57MB 数据结构 最短路径 java版 链表邻接表栈
1
数据结构与算法 中国矿业大学出版社 主编 张小燕 第三章 栈和队列
2021-12-26 18:26:57 528KB 数据结构与算法 第三章 栈和队列
1
顺序栈和链表栈(链栈)的初始化栈、判断栈是否为空、得到栈顶元素、清空栈、销毁栈、检测栈长度、入栈、出栈。程序可测试。
2021-12-26 13:43:34 90KB 栈 顺序栈 链表栈 C语言
1
python3.5全栈工程师零基础到项目实战全套,0基础教学,余生一起加油!!!
2021-12-26 11:31:56 64B 06.python3.5 0基础到精通 运维
1
本课程是针对零基础的前端入门实战案例课,通过讲解王者荣耀皮肤抽奖案例,帮助初学者快速入门学习前端开发,在案例中讲解HTML+CSS+JavaScript,零基础入门,如果你是前端开发的初学者,这套视频课程非常适合您! 以通俗易懂的方式讲解??王者荣耀皮肤抽奖??实战案例,真实、有趣、好玩!! 本案例的所有代码全程手敲,手把手的一行一行带你写,只讲干货,相信你看完后一定会收获很多!
1
C++ 用数组实现一个栈 很经典的 大家可以看看 学习学习
2021-12-24 15:42:08 454KB C++ 数组 栈
1
根据书中的伪代码实现的迷宫求解,但是并不是最优解,适合刚开始学栈的同学参考 #include #include #include #include #define TURE 1 #define FALSE 0 #define OK 1 #define ERROR 0 #define INFEASINLE -1 #define OVERFLOW -2 #define STACK_INIT_SIZE 100 #define STACKINCREMENT 10 #define MAXSIZE 100 //迷宫最大范围 #define ROW 10 //行数 #define COL 10
2021-12-24 15:31:12 59KB include 数据 数据结构
1
展讯协议栈LOG基础分析,比较好,可以拿来好好学习学习,特别是对初级中级者
2021-12-24 15:00:35 1.07MB 协议栈
1
本文主要介绍了如何开发基于TCP/IP 协议网络编程的自定义通讯协议. 在QNX.Linux和Windows三种不同的操作系统平台下实现多节点间的互相通讯。 测试结果表明,该协议可以方便高效地实现多平台下控制节点间的相互通讯.并且在长时间、高频率的通讯过程中,具有良好的实时性和可靠性。
2021-12-24 13:21:52 240KB linux网络 windows网络 tcp/ip
1
INTRODUCTION lwIP is a small independent implementation of the TCP/IP protocol suite. The focus of the lwIP TCP/IP implementation is to reduce the RAM usage while still having a full scale TCP. This making lwIP suitable for use in embedded systems with tens of kilobytes of free RAM and room for around 40 kilobytes of code ROM. lwIP was originally developed by Adam Dunkels at the Computer and Networks Architectures (CNA) lab at the Swedish Institute of Computer Science (SICS) and is now developed and maintained by a worldwide network of developers. FEATURES * IP (Internet Protocol, IPv4 and IPv6) including packet forwarding over multiple network interfaces * ICMP (Internet Control Message Protocol) for network maintenance and debugging * IGMP (Internet Group Management Protocol) for multicast traffic management * MLD (Multicast listener discovery for IPv6). Aims to be compliant with RFC 2710. No support for MLDv2 * ND (Neighbor discovery and stateless address autoconfiguration for IPv6). Aims to be compliant with RFC 4861 (Neighbor discovery) and RFC 4862 (Address autoconfiguration) * DHCP, AutoIP/APIPA (Zeroconf), ACD (Address Conflict Detection) and (stateless) DHCPv6 * UDP (User Datagram Protocol) including experimental UDP-lite extensions * TCP (Transmission Control Protocol) with congestion control, RTT estimation fast recovery/fast retransmit and sending SACKs * raw/native API for enhanced performance * Optional Berkeley-like socket API * TLS: optional layered TCP ("altcp") for nearly transparent TLS for any TCP-based protocol (ported to mbedTLS) (see changelog for more info) * PPPoS and PPPoE (Point-to-point protocol over Serial/Ethernet) * DNS (Domain name resolver incl. mDNS) * 6LoWPAN (via IEEE 802.15.4, BLE or ZEP) APPLICATIONS * HTTP server with SSI and CGI (HTTPS via altcp) * SNMPv2c agent with MIB compiler (Simple Network Management Protocol), v3 via altcp * SNTP (Simple network time protocol) * NetBIOS name service responder * MDNS (Multicast DNS) responder * iPerf server implementation * MQTT client (TLS support via altcp) LICENSE lwIP is freely available under a BSD license. DEVELOPMENT lwIP has grown into an excellent TCP/IP stack for embedded devices, and developers using the stack often submit bug fixes, improvements, and additions to the stack to further increase its usefulness. Development of lwIP is hosted on Savannah, a central point for software development, maintenance and distribution. Everyone can help improve lwIP by use of Savannah's interface, Git and the mailing list. A core team of developers will commit changes to the Git source tree. The lwIP TCP/IP stack is maintained in the 'lwip' Git module and contributions (such as platform ports) are in the 'contrib' Git module. See doc/savannah.txt for details on Git server access for users and developers. The current Git trees are web-browsable: http://git.savannah.gnu.org/cgit/lwip.git http://git.savannah.gnu.org/cgit/lwip/lwip-contrib.git Submit patches and bugs via the lwIP project page: http://savannah.nongnu.org/projects/lwip/ Continuous integration builds (GCC, clang): https://travis-ci.org/lwip-tcpip/lwip DOCUMENTATION Self documentation of the source code is regularly extracted from the current Git sources and is available from this web page: http://www.nongnu.org/lwip/ Also, there are mailing lists you can subscribe at http://savannah.nongnu.org/mail/?group=lwip plus searchable archives: http://lists.nongnu.org/archive/html/lwip-users/ http://lists.nongnu.org/archive/html/lwip-devel/ There is a wiki about lwIP at http://lwip.wikia.com/wiki/LwIP_Wiki You might get questions answered there, but unfortunately, it is not as well maintained as it should be. lwIP was originally written by Adam Dunkels: http://dunkels.com/adam/ Reading Adam's papers, the files in docs/, browsing the source code documentation and browsing the mailing list archives is a good way to become familiar with the design of lwIP. Adam Dunkels Leon Woestenberg
2021-12-24 09:22:48 12.83MB lwIP.
1